Welcome

You are here: Welcome

AgMD1 Digitizers

LabVIEW G Programming Information

This help file contains LabVIEW G programming guidelines and reference information for the AgMD1 Digitizers.

Programming Guide

Scenarios and Sample Programs

M9703A in DDC mode

M9202A in DDC mode

Programming Reference

AgMD1 Methods (VIs)

AgMD1 Attributes

© 2010 - 2012 Agilent Technologies, Inc. | Help version 1.3.3
Part No: M9202-90004 | 28/09/2012


Programming Reference

You are here: AgMD1 LabVIEW G Driver > Programming Reference

Programming Guide

This section provides information and examples for using the MD1 LabVIEW G Driver

The Agilent AgMD1 driver for LabVIEW conforms to National Instruments' Instrument Driver Standard. If LabVIEW is installed on the target machine when the AgMD1 software is installed, the driver interfaces will be copied to the LabVIEW n\Instr.lib directory.

  • The driver function VI’s can then be found on the Functions palette (block diagram), Instrument Drivers subpalette.
  • The Agilent AgMD1 folder contains an Agilent AgMD1.lvproj which could be a good starting point for your development. See the front panel image below.
  • Opening this project gives access to an examples listed below:

Scenarios and Sample Programs

Example: Getting Started

Example: Getting Started with Measuement Fetch Example

Example: Edge Triggered Waveform Acquisition

M9703A in DDC mode

M9202A in DDC mode


Scenarios and Sample Programs

The following example programs are provided to demonstrate certain features in a typical AgMD1 supported Digitizer.

Each example VI has a front panel you can use to exercise the underlying VI functions.

Example: Getting Started

Example: Getting Started with Measuement Fetch Example

Example: Edge Triggered Waveform Acquisition


AgMD1: Getting Started Example

GettingStarted.vi

This example VI covers some of the basic operations when working with an instrument in the Agilent MD1 driver.

Description

This example configures Acquisition, Channel and Trigger Parameters in accordance with the capabilities of the module used.

The sequence on the Block Diagram is as follows:

  1. Initialize with options
  2. Check initialization: quiery model name
  3. Configure channel parameters and impedance
  4. Configure acquisition parameters
  5. Configure edge trigger
  6. Start Acquisition
  7. Read Waveform and display
  8. Close

The error handler at the end of the sequence will dialog the user for any errors encountered.


AgMD1: Getting Started with Measurement Fetch Example

GettingStartedwithMeasurementFetch.vi

This example configures Acquisition, Channel and Trigger Parameters in accordance with the capabilities of the module used. The example also demonstrates how to Fetch measurements.

Description

The sequence on the Block Diagram is as follows:

  1. Initialize with options
  2. Check initialization: query model name
  3. Configure channel parameters and impedance
  4. Configure acquisition parameters
  5. Configure edge trigger
  6. Start Acquisition\
  7. Read Waveform and display
  8. Fetch measurements in to an array
  9. Close

The error handler at the end of the sequence will dialog the user for any errors encountered.


AgMD1: Edge Triggered Waveform Acquisition Example

EdgeTriggeredWaveformAcquisition.vi

This example shows how to acquire a waveform utilizing the MD1 Digitizer Driver, and also demonstrates how to Fetch measurements.

Description

The best setting for this example is to connect a stimulus waveform to Channel 1 with the following parameters:

  • Shape: Sine
  • Amplitude: 5 Vp-p
  • Frequency: 1 MHz

The sequence on the Block Diagram is as follows:

  1. Initialize
  2. Configure Channel
  3. Configure Acquisition
  4. Configure Trigger
  5. Read Waveform
  6. Fetch Measurements
  7. Close

The error handler at the end of the sequence will dialog the user for any errors encountered.


M9703A Digitizer in DDC mode

Configuration and operation of the M9703A in DDC mode requires the use of the following VIs (methods):

AgMD1: Configure Downconversion

And the following attributes, which may be accessed using the Get/Set Attribute functions:

DOWNCONVERSION_ENABLED

DOWNCONVERSION_CENTER_FREQUENCY

DOWNCONVERSION_IQ_INTERLEAVED

Important notes

When using the M9703A AXIe digitizer in its optional DDC mode, several points should be noted when programming.

When downconversion is enabled, the following applies:

  • Read/Fetch/Fetch Multi-Record methods in Real64 are supported for all sample rates.
  • Read/Fetch/Fetch Multi-Record methods in Int16 are supported for the highest sample rate only.
  • The Read/Fetch/Fetch Multi-Record methods in Int32 are supported for all except the highest sample rate.

For these methods, the parameter ActualPoints is given in number of I-Q data point pairs, or complex samples.

For the Fetch Multi-Record methods, the units of the OffsetWithinRecord and NumPointsPerRecord parameters are also complex samples.

The FirstValidPoint parameter, which is primarily intended for dealing with memory alignment, is always given in array elements, like the WaveformArraySize parameter.


M9202A Digitizer in DDC mode

Configuration and operation of the M9202A in DDC mode requires the use of the following VIs (methods):

AgMD1: Digital Downconversion Configure

And the following attributes, which may be accessed using the Get/Set Attribute functions:

ACQUISITION_MODE

DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH

DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED

DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT

DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH

Important Notes

When using the M9202A PXIe digitizer in its optional DDC mode, several points should be noted when programming.

When in digital downconversion mode, the following applies:

  • Read/Fetch/Fetch Multi-Record methods in Real64 are supported for all sample rates.
  • Read/Fetch/Fetch Multi-Record methods in Int16 are supported for all sample rates.

For these methods, the parameter ActualPoints is given in data samples. i.e.twice the number of I-Q data point pairs, or complex samples.

The FirstValidPoint parameter, which is primarily intended for dealing with memory alignment, is always given in array elements, like the WaveformArraySize parameter.


Programming Reference

This section provides information on each of the VI's and the associated Attributes in the MD1 LabVIEW G Driver

AgMD1 Methods (VIs)

VI Tree

Initialize

Initialize with Options

Close

Action-Status

Configuration

Data

Utility

AgMD1 Attributes

ACQUISITION_AUTO_ARM_ENABLED

ACQUISITION_DITHER_ENABLED

ACQUISITION_DITHER_RANGE

ACQUISITION_MODE

ACQUISITION_NUMBER_OF_AVERAGES

ACQUISITION_REFERENCE_CHANNEL

ACQUISITION_START_TIME

ACQUISITION_TIME_PER_RECORD

ACTIVE_TRIGGER_SOURCE

BOARD_TEMPERATURE

CHANNEL_ACTIVE_INPUTS

CHANNEL_CONNECTOR_NAME

CHANNEL_CONVERTERS_PER_CHANNEL

CHANNEL_COUNT

CHANNEL_ENABLED

CHANNEL_INPUT_FREQUENCY_MAX

CHANNEL_PROBE_ATTENUATION

CHANNEL_TEMPERATURE

CONTROL_IO_SIGNAL_A

CONTROL_IO_SIGNAL_B

CONTROL_IO_SIGNAL_C

COUNTER_APETURE_TIME

COUNTER_MODE

DELAY_CONTROL_COUNT

DELAY_CONTROL_ENABLE

DELAY_CONTROL_MAX

DELAY_CONTROL_MIN

DELAY_CONTROL_VALUE

DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH

DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED

DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT

DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH

DOWNCONVERSION_CENTER_FREQUENCY

DOWNCONVERSION_ENABLED

DOWNCONVERSION_IQ_INTERLEAVED

DRIVER_SETUP

EXT_TRIG_RANGE

INPUT_CONNECTOR_SELECTION

INPUT_FILTER_BYPASS

INPUT_FILTER_MAX_FREQUENCY

INPUT_IMPEDANCE

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_INFO_AQ_DRV_VERSION

INSTRUMENT_INFO_AQIO_VERSION

INSTRUMENT_INFO_BUS_NUMBER

INSTRUMENT_INFO_CPLD_FIRMWARE_REV

INSTRUMENT_INFO_CRATE_ID

INSTRUMENT_INFO_CRATE_NUMBER

INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV

INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV

INSTRUMENT_INFO_FUNDAMENTAL_HANDLE

INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE

INSTRUMENT_INFO_NBRADC_BITS

INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS

INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS

INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT

INSTRUMENT_INFO_OPTIONS

INSTRUMENT_INFO_SERIAL_NUMBER

INSTRUMENT_INFO_SERIAL_NUMBER_STRING

INSTRUMENT_INFO_SLOT_NUMBER

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_RESOURCE_DESCRIPTOR

IS_IDLE

IS_MEASURING

IS_WAITING_FOR_ARM

IS_WAITING_FOR_TRIGGER

LOGICAL_NAME

LOGIC_DEVICE_COUNT

MAX_FIRST_VALID_POINT_VAL

MAX_SAMPLES_PER_CHANNEL

MEASUREMENT_WAVEFORM_TYPE

MIN_RECORD_SIZE

NUM_ACQUIRED_RECORDS

NUM_RECORDS_TO_ACQUIRE

PXI_TRIG_OUT_ENABLED

PXI_TRIG_SLOPE

RECORD_SIZE

REFERENCE_LEVEL_HIGH

REFERENCE_LEVEL_LOW

REFERENCE_LEVEL_MID

REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

REFERENCE_OSCILLATOR_SOURCE

REFERENCE_OSCILLATOR_OUTPUT_ENABLED

SAMPLE_CLOCK_EXTERNAL_DIVIDER

SAMPLE_CLOCK_EXTERNAL_FREQUENCY

SAMPLE_CLOCK_SOURCE

SAMPLE_MODE

SAMPLE_RATE

SIMULATE

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

SUPPORTED_INSTRUMENT_MODELS

SYSTEM_TRACE_ENABLED

SYSTEM_NBR_INSTRUMENTS

TEMPERATURE_UNITS

TIME_INTERLEAVED_CHANNEL_LIST

TRIGGER_COUPLING

TRIGGER_DELAY

TRIGGER_LEVEL

TRIGGER_MAGNITUDE_SLOPE

TRIGGER_MODIFIER

TRIGGER_OUTPUT_ENABLED

TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED

TRIGGER_OUTPUT_OFFSET

TRIGGER_OUTPUT_RESYNC

TRIGGER_OUTPUT_SOURCE

TRIGGER_SLOPE

TRIGGER_SOURCE_COUNT

TRIGGER_SOURCE_LIST

TRIGGER_SOURCE_OPERATOR

TRIGGER_TYPE

TV_TRIGGER_POLARITY

TV_TRIGGER_EVENT

TV_TRIGGER_LINE_NUMBER

TV_TRIGGER_SIGNAL_FORMAT

VERTICAL_COUPLING

VERTICAL_OFFSET

VERTICAL_RANGE


AgMD1 Methods (VI's)

You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Methods (VI's)

Agilent AgMD1 Methods (VI's)

This section provides technical and programming support for using the Agilent AgMD1 LabVIEW API VIs to develop applications for your Digitizers.

The VI's are split into the following main topics, depending on their function:

VI Tree

Initialize

Initialize with Options

Close

Action-Status

Get Channel Name

Get Trigger Source Name

Send Software Arm

Send Software Trigger

Low Level

Configuration

Acquisition Configure Record

Configure Acquisition Record

Configure Channel

Configure Downconversion

Configure Edge Trigger Source

Configure Multi Trigger

Configure Reference Oscillator Output Enabled

Configure Sample Mode

Configure Temperature Units

Configure Trigger Modifier

Configure TV Trigger Source

Digital Downconversion Configure

Reference Level Configure

Trigger Magnitude Configure

Low Level

Data

Counter Read

Fetch Multi-Record Waveform Int8

Fetch Multi-Record Waveform Int16

Fetch Multi-Record Waveform Int32

Fetch Multi-Record Waveform Real64

Measurement Fetch Waveform Measurement

Measurement Read Waveform Measurement

Query Board Temperature

Query Channel Temperature

Read Waveform Int8

Read Waveform Int16

Read Waveform Int32

Read Waveform Real64

Temperature Get Module Temperature

Low Level

Utility

Calibration Cal Required

Calibration Cancel

Calibration Load Cal

Calibration Save Cal

Calibration Self Calibrate

Disable

Error Message

Error Query

Get Delay Control Name

Reset

Resume Control

Suspend Control

Revision Query

Self Calibrate

Self Test

System Power Off All

System Power On All


AgMD1: VI Tree

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.


AgMD1: Initialize

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Inputs

resource string

The resource name that specifies the address of the PXI module. This may also be an IVI logical name.

id query (Off)

Specifies whether to verify the ID of the instrument.

reset device (Off)

Specifies whether to reset the instrument.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Initialize with Options

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Inputs

resource string

The resource name that specifies the address of the PXI module. This may be an IVI logical name.

id query (Off)

Specifies whether to verify the ID of the instrument.

reset device (Off)

Specifies whether to reset the instrument.

option string

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent properties for the session. The format of an assignment in the OptionsString parameteris "Name=Value", where Name is one of:

Name | Value
Simulate | True / False
DriverSetup | (see below)

If the Options String parameter contains an assignment for the Driver Setup property, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Close

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Action Status VI's

You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Methods (VIs) > Action Status VI's

Action Status

Contained in this section are VI's which control the status or initiate actions within the instrument.

Get Channel Name

Get Trigger Source Name

Send Software Arm

Send Software Trigger

Low Level

Abort

Initiate Acquisition

Is Idle

Is Measuring

Is Waiting for Arm

Is Waiting For Trigger

Query Min Waveform Memory

Wait For Acquisition Complete


AgMD1: Get Channel Name

This VI returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Channel Count, the VI returns an empty string in the Name parameter and returns an error.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Index (0)

A one-based index that defines which name to return

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Channel Name

A string containing the channel name.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Get Trigger Source Name

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Source Index (0)

A one-based index that defines which name to return.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Source Name

A string containing the channel name.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Send Software Arm

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Send Software Trigger

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Action Status \ Low Level VIs

You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Methods (VIs) > Action Status \ Low Level VIs

Action-Status \ Low-level VIs

Contained in this section are VI's which are used to access the low-level operations of the instrument.

Abort

Initiate Acquisition

Is Idle

Is Measuring

Is Waiting for Arm

Is Waiting For Trigger

Query Min Waveform Memory

Wait For Acquisition Complete


AgMD1: Abort

Aborts an acquisition and returns the digitizer to the Idle state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Initiate Acquisition

Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Is Idle

This function is used to determine if the digitizer is currently in the Idle state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Idle state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned value | Meaning
AcquisitionStatusResultTrue | The digitizer is currently in the Idle state
AcquisitionStatusResultFalse | The digitizer is not currently in the Idle state
AcquisitionStatusResultUnknown | The driver cannot query the instrument to determine the digitizer state

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Is Measuring

This function is used to determine if the digitizer is currently in the Measuring state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Measuring state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned value | Meaning
AcquisitionStatusResultTrue | The digitizer is currently in the Measuring state
AcquisitionStatusResultFalse | The digitizer is not currently in the Measuring state
AcquisitionStatusResultUnknown | The driver cannot query the instrument to determine the digitizer state

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Is Waiting for Arm

This function is used to determine if the digitizer is currently in the Waiting For Arm state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the WaitingForArm state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned value | Meaning
AcquisitionStatusResultTrue | The digitizer is currently waiting for Arm
AcquisitionStatusResultFalse | The digitizer is not currently waiting for Arm
AcquisitionStatusResultUnknown | The driver cannot query the instrument to determine the digitizer state

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Is Waiting For Trigger

This function is used to determine if the digitizer is currently in the Waiting For Trigger state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the WaitingForTrigger state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Returned value | Meaning
AcquisitionStatusResultTrue | The digitizer is currently waiting for Trigger
AcquisitionStatusResultFalse | The digitizer is not currently waiting for Trigger
AcquisitionStatusResultUnknown | The driver cannot query the instrument to determine the digitizer state

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Query Min Waveform Memory

This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Data Width (0)

Specifies the size of the sampled data that will be retrieved. The value of this parameter must be 8, 16, 32 or 64, corresponding to the intended Read/Fetch function.

Number of Records (0)

Specifies the number of records that will be read.

Offset Within Record (0)

Specifies the start index within the record from which the data should be retrieved.

Number of Points Per Record (0)

Specifies the number of data points to return.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Number of Samples

The minimum buffer size in samples needed for a subsequent Read or Fetch call with the same readout parameters.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Wait For Acquisition Complete

Waits until the configured acquisition is complete.

If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the Maximum Time parameter, the function returns the Max Time Exceeded error.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Maximum Time (0)

Specifies the maximum time the end-user allows for this function to complete. The units are milliseconds. Use '0' for immediate (no wait), and '-1' to wait indefinitely.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Configuration VIs

Contained in this section are VI's which are used to configure the instrument.

Acquisition Configure Record

Configure Acquisition Record

Configure Channel

Configure Downconversion

Configure Edge Trigger Source

Configure Multi Trigger

Configure Reference Oscillator Output Enabled

Configure Sample Mode

Configure Temperature Units

Configure Trigger Modifier

Configure TV Trigger Source

Digital Downconversion Configure

Reference Level Configure

Trigger Magnitude Configure

Low Level

Get Attribute ViBoolean

Get Attribute ViInt32

Get Attribute ViInt64

Get Attribute ViReal64

Get Attribute ViString

Set Attribute ViBoolean

Set Attribute ViInt32

Set Attribute ViInt64

Set Attribute ViReal64

Set Attribute ViString


AgMD1: Acquisition Configure Record

This function configures the most commonly used properties of the digitizer acquisition subsystem when used as an oscilloscope: time per record, minimum record length, and the acquisition start time. This function is included to retain compatibility with the IVI 'Scope' class.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Time Per Record (0)

Min Num Pts (0)

Acquisition Start Time (0)

The length of time from the trigger event to the first point in the waveform record. The units are seconds.
If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Acquisition Record

This VI configures the most commonly configured properties of the digitizer acquisition sub-system. These properties are the samples per record, the number of records, and the sample rate.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Num Records To Acquire (0)

Specifies the number of records in the acquisition.

Record Size (0)

Specifies the number of samples in each record.

Sample Rate (0)

Specifies the sample rate in samples per second.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Channel

This VI configures the most commonly configured properties of the digitizer channel sub-system. These properties are the range, offset, coupling, probe attenuation, and whether the channel is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Vertical Range (0)

Specifies the vertical range.

Vertical Offset (0)

Specifies the vertical offset.

Vertical Coupling (AC)

Specifies how to couple the input signal. Supported values are:

Name | Description
AC | The digitizer AC couples the input signal.
DC | The digitizer DC couples the input signal.
GND | The digitizer couples the channel to the ground.

Channel Enabled (Off)

Specifies if the channel is enabled for acquisition.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Downconversion

Configures Digital Downconversion (DDC) operation on supported models.

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requires model : M9703A with -DDC option.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Channel Name
The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Downconversion Enabled (Off)
Enables or disables downconversion.

Center Frequency
Specifies the center frequency, in Hz, from which the digitizer should downconvert.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Edge Trigger Source

This function sets the edge triggering properties. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter.
This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Source

Specifies the trigger source. Supported values are:

Name | Description
Channel<n> | Triggers from the channel specified, where <n> is a valid channel number.
External<n> | Triggers from external trigger input specified, where <n> is a valid external trigger input number.
PXI_STAR | Triggers from the PXI Bus Star Trigger.

Trigger Level (0)

Specifies the trigger level.

Trigger Slope (Negative)

Specifies the trigger slope. Supported values are:

Name | Description
Negative | A negative (falling) edge passing through the trigger level triggers the digitizer.
Positive | A positive (rising) edge passing through the trigger level triggers the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Multi Trigger

Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Source List

A comma separated list of source names to be used in a multi trigger scenario. Valid trigger source names are:

Name | Description
Channel1 | Triggers from channel 1
Channel2 | Triggers from channel 2 (If support on the instrument)
External1 | Triggers from External Trigger Input 1

Trigger Source Operator (AND)

Specifies the boolean operation to apply to the trigger sources specified by the SourceList parameter.

Name | Description
AND | Trigger sources are AND'd together. The digitizer triggers when all configured trigger source conditions are satisfied.
OR | Trigger sources are OR'd together. The digitizer triggers when the first configured trigger source condition is satisfied.
None | No operator is applied to the configured list of trigger sources. The trigger source list is ignored, and the digitizer triggers when the currently configured trigger source, given by the Trigger Source attribute, and its associated trigger conditions are satisfied.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Reference Oscillator Output Enabled

Configures whether or not the reference frequency signal appears at an output of the digitizer.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Output Enabled (Off)

Specifies whether or not the reference frequency signal appears at a reference output of the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Sample Mode

Configures the digitizer sample mode.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Sample Mode (Real Time)

Specifies the sample mode used by the digitizer. Supported values are:

Name | Description
Real Time | Real-time sampling is used.
Equivalent Time | Equivalent-time sampling is used.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Temperature Units

This function is used to configure the temperature units returned by the Board Temperature and the Channel Temperature properties.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Temperature Units (Celsius)

Temperature units to be used by the Board Temperature and Channel Temperature properties.Supported values are:

Name | Description
Celsius | Temperature values returned from the digitizer are in degrees Celsius.
Fahrenheit | Temperature values returned from the digitizer are in degrees Fahrenheit.
Kelvin | Temperature values returned from the digitizer are in degrees Kelvin.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure Trigger Modifier

This VI configures the digitizer's trigger modifier.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Modifier (None)

Specifies the method the digitizer uses in the absence of trigger conditions. Supported values are:

Name | Description
None | The digitizer waits until the trigger the end-user specifies occurs.
Auto | The digitizer automatically triggers if the configured trigger does not occur within the digitizer timeout period.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Configure TV Trigger Source

This VI configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Trigger Source

Specifies the trigger source

Signal Format (NTSC)

Specifies the TV trigger signal format. Supported values are:

Name | Description
NTSC | Configures the digitizer to trigger on the NTSC signal format.
PAL | Configures the digitizer to trigger on the PAL signal format
SECAM | Configures the digitizer to trigger on the SECAM signal format

Trigger Event (Field1)

Specifies the TV trigger event. Supported values are:

Name | Description
Field1 | Sets the digitizer to trigger on field 1 of the video signal.
Field2 | Sets the digitizer to trigger on field 2 of the video signal.
LineNumber | Sets the digitizer to trigger on a specific line number you specify with the TV Trigger Line Number attribute.

TV Polarity (Positive)

Specifies the polarity of the TV trigger. Supported values are:

Name | Description
Positive | Configures the digitizer to trigger on a positive video sync pulse.
Negative | Configures the digitizer to trigger on a negative video sync pulse.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Digital Downconversion Configure

Configures the DigitalDownconverson DataBandwidth and TriggerBandwidth.

Requires Model: M9202A

Please refer to the Remarks in the M9202A Digitizer in DDC mode topic for detailed information on programming when in digital downconversion mode.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Data Bandwidth (0)

The output bandwidth in Hz for down-converted data.

Trigger Bandwidth (0)

The output bandwidth in Hz for down-converted trigger.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Reference Level Configure

Configures the reference levels for waveform measurements, low, mid, and high.

Low & High are used for measurements such as Rise Time and Fall Time, and Mid is used in measurements such as Duty Cycle and Width. See MeasurementFetchWaveformMeasurement for more details.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Low (0)

The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Mid (0)

The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

High (0)

The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1 : Trigger Magnitude Configure

This function sets the magnitude triggering attributes when used with a down-converted Digital Down Converter (DDC) signal.

The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and Trigger Type = Magnitude before calling this function. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Hysteresis
Specifies the trigger hysteresis in Volts.

TriggerSource
The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single trigger source.

Level
Specifies the trigger level in Volts.

Slope (Trigger Slope Negative)
Specifies whether a rising (Positive) or a falling (Negative) edge triggers the digitizer.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Configuration \ Low Level VIs

You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Methods (VIs) > Configuration \ Low Level VIs

Configuration \ Low-level VIs

Contained in this section are VI's which are used to access the low-level operations of the instrument.

Get Attribute ViBoolean

Get Attribute ViInt32

Get Attribute ViInt64

Get Attribute ViReal64

Get Attribute ViString

Set Attribute ViBoolean

Set Attribute ViInt32

Set Attribute ViInt64

Set Attribute ViReal64

Set Attribute ViString


AgMD1: Get Attribute ViBoolean

Gets a Boolean attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

Atrribute ID

The following Attributes are supported:

Attribute ID
INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE
SIMULATE
CHANNEL_ENABLED
INPUT_FILTER_BYPASS
REFERENCE_OSCILLATOR_OUTPUT_ENABLED
TRIGGER_OUTPUT_ENABLED
ACQUISITION_DITHER_ENABLED
ACQUISITION_AUTO_ARM_ENABLED
DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED
SYSTEM_TRACE_ENABLED
PXI_TRIG_OUT_ENABLED
TRIGGER_OUTPUT_RESYNC
TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Attribute Value

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Get Attribute ViInt32

Gets an Int32 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

Attribute ID

The following Attributes are supported:
CHANNEL_COUNT
IS_IDLE
IS_MEASURING
IS_WAITING_FOR_ARM
IS_WAITING_FOR_TRIGGER
TRIGGER_SOURCE_COUNT
CHANNEL_CONVERTERS_PER_CHANNEL
SYSTEM_NBR_INSTRUMENTS
INSTRUMENT_INFO_BUS_NUMBER
INSTRUMENT_INFO_CRATE_NUMBER
INSTRUMENT_INFO_DEVICE_ID
INSTRUMENT_INFO_NBRADC_BITS
INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS
INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS
INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT
INSTRUMENT_INFO_SERIAL_NUMBER
INSTRUMENT_INFO_SLOT_NUMBER
TEMPERATURE_UNITS
SAMPLE_MODE
VERTICAL_COUPLING
INPUT_CONNECTOR_SELECTION
REFERENCE_OSCILLATOR_SOURCE
SAMPLE_CLOCK_SOURCE
TRIGGER_COUPLING
TRIGGER_TYPE
TRIGGER_MODIFIER
TRIGGER_SLOPE
TV_TRIGGER_POLARITY
TV_TRIGGER_EVENT
TV_TRIGGER_LINE_NUMBER
TV_TRIGGER_SIGNAL_FORMAT
TRIGGER_SOURCE_OPERATOR
ACQUISITION_NUMBER_OF_AVERAGES
ACQUISITION_DITHER_RANGE
ACQUISITION_MODE
MEASUREMENT_WAVEFORM_TYPE
COUNTER_MODE
PXI_TRIG_SLOPE
TRIGGER_MAGNITUDE_SLOPE
INSTRUMENT_INFO_FUNDAMENTAL_HANDLE

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Attribute Value

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Get Attribute ViInt64

Gets an Int64 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Attribute ID

The following Attributes are supported:

Attributes
MAX_SAMPLES_PER_CHANNEL
NUM_ACQUIRED_RECORDS
MIN_RECORD_SIZE
RECORD_SIZE
NUM_RECORDS_TO_ACQUIRE
MAX_FIRST_VALID_POINT_VAL

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Attribute Value

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Get Attribute ViReal64

Gets a Real64 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

Attribute ID

The following Attributes are supported:

Supported Attributes
CHANNEL_TEMPERATURE
BOARD_TEMPERATURE
SAMPLE_RATE
INPUT_IMPEDANCE
VERTICAL_RANGE
VERTICAL_OFFSET
INPUT_FILTER_MAX_FREQUENCY
REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY
SAMPLE_CLOCK_EXTERNAL_FREQUENCY
SAMPLE_CLOCK_EXTERNAL_DIVIDER
TRIGGER_LEVEL
TRIGGER_DELAY
ACQUISITION_START_TIME
ACQUISITION_TIME_PER_RECORD
CHANNEL_INPUT_FREQUENCY_MAX
CHANNEL_PROBE_ATTENUATION
DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH
DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH
DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT
REFERENCE_LEVEL_HIGH
REFERENCE_LEVEL_LOW
REFERENCE_LEVEL_MID
TRIGGER_OUTPUT_OFFSET
COUNTER_APETURE_TIME
EXT_TRIG_RANGE

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Attribute Value

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Get Attribute ViString

Gets a String attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

Attribute ID

The following Attributes are supported:
SPECIFIC_DRIVER_DESCRIPTION
SPECIFIC_DRIVER_VENDOR
SPECIFIC_DRIVER_REVISION
LOGICAL_NAME
IO_RESOURCE_DESCRIPTOR
DRIVER_SETUP
SUPPORTED_INSTRUMENT_MODELS
INSTRUMENT_FIRMWARE_REVISION
INSTRUMENT_MANUFACTURER
INSTRUMENT_MODEL
CHANNEL_CONNECTOR_NAME
INSTRUMENT_INFO_AQ_DRV_VERSION
INSTRUMENT_INFO_AQIO_VERSION
INSTRUMENT_INFO_CPLD_FIRMWARE_REV
INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV
INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV
INSTRUMENT_INFO_OPTIONS
TIME_INTERLEAVED_CHANNEL_LIST
ACTIVE_TRIGGER_SOURCE
TRIGGER_SOURCE_LIST
ACQUISITION_REFERENCE_CHANNEL
CHANNEL_ACTIVE_INPUTS
CONTROL_IO_SIGNAL_A
CONTROL_IO_SIGNAL_B
CONTROL_IO_SIGNAL_C
TRIGGER_OUTPUT_SOURCE
INSTRUMENT_INFO SERIAL_NUMBER_STRING

Attribute Value Buffer Size

The number of bytes in the string that the user specifies for the AttributeValue parameter.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Attribute Value

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Set Attribute ViBoolean

Sets a Boolean attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

Atrribute ID

The following Attributes are supported:

Attribute ID
SIMULATE
CHANNEL_ENABLED
INPUT_FILTER_BYPASS
REFERENCE_OSCILLATOR_OUTPUT_ENABLED
TRIGGER_OUTPUT_ENABLED
ACQUISITION_DITHER_ENABLED
ACQUISITION_AUTO_ARM_ENABLED
DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED
SYSTEM_TRACE_ENABLED
PXI_TRIG_OUT_ENABLED
TRIGGER_OUTPUT_RESYNC
TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED

Attribute Value

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Set Attribute ViInt32

Sets an Int32 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

Attribute ID

The following Attributes are supported:

Supported Attributes
TEMPERATURE_UNITS
SAMPLE_MODE
VERTICAL_COUPLING
INPUT_CONNECTOR_SELECTION
REFERENCE_OSCILLATOR_SOURCE
SAMPLE_CLOCK_SOURCE
TRIGGER_COUPLING
TRIGGER_TYPE
TRIGGER_MODIFIER
TRIGGER_SLOPE
TV_TRIGGER_POLARITY
TV_TRIGGER_EVENT
TV_TRIGGER_LINE_NUMBER
TV_TRIGGER_SIGNAL_FORMAT
TRIGGER_SOURCE_OPERATOR
ACQUISITION_NUMBER_OF_AVERAGES
ACQUISITION_DITHER_RANGE
ACQUISITION_MODE
MEASUREMENT_WAVEFORM_TYPE
COUNTER_MODE
PXI_TRIG_SLOPE
TRIGGER_MAGNITUDE_SLOPE

Attribute Value

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Set Attribute ViInt64

Sets an Int64 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Attribute ID

The following Attributes are supported:

Attributes
RECORD_SIZE
NUM_RECORDS_TO_ACQUIRE
MAX_FIRST_VALID_POINT_VAL

Attribute Value

Sets the value of the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Set Attribute ViReal64

Sets a Real64 attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

Attribute ID

The following Attributes are supported:

Supported Attributes
SAMPLE_RATE
INPUT_IMPEDANCE
VERTICAL_RANGE
VERTICAL_OFFSET
INPUT_FILTER_MAX_FREQUENCY
REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY
SAMPLE_CLOCK_EXTERNAL_FREQUENCY
SAMPLE_CLOCK_EXTERNAL_DIVIDER
TRIGGER_LEVEL
TRIGGER_DELAY
ACQUISITION_START_TIME
ACQUISITION_TIME_PER_RECORD
CHANNEL_INPUT_FREQUENCY_MAX
CHANNEL_PROBE_ATTENUATION
DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH
DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH
DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT
REFERENCE_LEVEL_HIGH
REFERENCE_LEVEL_LOW
REFERENCE_LEVEL_MID
TRIGGER_OUTPUT_OFFSET
COUNTER_APETURE_TIME
EXT_TRIG_RANGE

Attribute Value

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Set Attribute ViString

Sets a String attribute from the instrument driver.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

Attribute ID

The following Attributes are supported:
TIME_INTERLEAVED_CHANNEL_LIST
ACTIVE_TRIGGER_SOURCE
TRIGGER_SOURCE_LIST
ACQUISITION_REFERENCE_CHANNEL
CHANNEL_ACTIVE_INPUTS
CONTROL_IO_SIGNAL_A
CONTROL_IO_SIGNAL_B
CONTROL_IO_SIGNAL_C
TRIGGER_OUTPUT_SOURCE

Attribute Value

The value to which to set the property.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Data VIs

Contained in this section are VI's which are used to collect data from the instrument.

Counter Read

Fetch Multi-Record Waveform Int8

Fetch Multi-Record Waveform Int16

Fetch Multi-Record Waveform Int32

Fetch Multi-Record Waveform Real64

Measurement Fetch Waveform Measurement

Measurement Read Waveform Measurement

Query Board Temperature

Query Channel Temperature

Read Waveform Int8

Read Waveform Int16

Read Waveform Int32

Read Waveform Real64

Temperature Get Module Temperature

Low Level

Fetch Waveform Int8

Fetch Waveform Int16

Fetch Waveform Int32

Fetch Waveform Real64


AgMD1 : Counter Read

Counter measurement results for the current mode.

Counter must be enabled by setting Counter Mode The Read method will wait the current Counter ApertureTime before returning measurement data. Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL (0) if the operation does not apply to a repeated capability. You can also pass VI_NULL (0) if the device only has a single channel.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Val

Measurement data. Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Fetch Multi-Record Waveform Int8

This VI returns the (multi-record) waveform the digitizer acquired for the specified channel.
The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values.
Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type.
Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

First Record (0)

Specifies the number of the first record to read.

Num Records (0)

Specifies the number of consecutive records to read.

Offset Within Record (0)

Specifies the start index within the record from which the data should be retrieved

Num Points Per Record (0)

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

Waveform Array Buffer Size (0)

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Waveform Array

Buffer into which the acquired waveform is stored.

Waveform Array Actual Size

Actual number of elements in WaveformArray.

Actual Records

Indicates how many records in the acquisition completed successfully.

Actual Points

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

First Valid Point

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Fetch Multi-Record Waveform Int16

This VI returns the (multi-record) waveform the digitizer acquired for the specified channel.
The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

First Record (0)

Specifies the number of the first record to read.

Num Records (0)

Specifies the number of consecutive records to read.

Offset Within Record (0)

Specifies the start index within the record from which the data should be retrieved

Num Points Per Record (0)

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

Waveform Array Buffer Size (0)

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Waveform Array Actual Size

Actual number of elements in WaveformArray.

Actual Records

Indicates how many records in the acquisition completed successfully.

Actual Points

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

First Valid Point

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Fetch Multi-Record Waveform Int32

This VI returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

First Record (0)

Specifies the number of the first record to read.

Num Records (0)

Specifies the number of consecutive records to read.

Offset Within Record (0)

Specifies the start index within the record from which the data should be retrieved

Num Points Per Record (0)

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

Waveform Array Buffer Size (0)

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Waveform Array Actual Size

Actual number of elements in WaveformArray.

Actual Records

Indicates how many records in the acquisition completed successfully.

Actual Points

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

First Valid Point

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Fetch Multi-Record Waveform Real64

This VI returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

First Record (0)

Specifies the number of the first record to read.

Num Records (0)

Specifies the number of consecutive records to read.

Offset Within Record (0)

Specifies the start index within the record from which the data should be retrieved

Num Points Per Record (0)

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

Waveform Array Buffer Size (0)

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Waveform Array Actual Size

Actual number of elements in WaveformArray.

Actual Records

Indicates how many records in the acquisition completed successfully.

Actual Points

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

Numeric

First Valid Point

Indicates the index of the first valid data point in the output data array for each completed record.

Numeric

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Measurement Fetch Waveform Measurement

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

MeasFunction (Rise Time)

Requests one of the measurement functions to be performed on the acquired waveform. Note: reference levels used by these measurements may be set using the Reference Level Configure VI
Supported functions are:

Name | Description
RiseTime | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
FallTime | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
Frequency | The frequency of one complete cycle in the waveform. The units are Hertz.
Period | The length of time of one complete cycle in the waveform. The units are seconds.
VoltageRMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
VoltagePeakToPeak | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
VoltageMax | The maximum amplitude found in the entire waveform. The units are Volts.
VoltageMin | The minimum amplitude found in the entire waveform. The units are Volts.
VoltageHigh | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.
VoltageLow | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.
VoltageAverage | The arithmetic average in volts measured over the entire waveform. The units are Volts.
WidthNeg | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
WidthPos | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
DutyCycleNeg | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
DutyCyclePos | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
Amplitude | The Voltage High less the Voltage Low in Volts over the entire waveform.
VoltageCycleRMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
VoltageCycleAverage | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
OverShoot | The relative waveform distortion that follows an edge transition.
PreShoot | The relative waveform distortion that precedes an edge transition.
DCOffset | The DC offset voltage.
PhaseAngle | The phase angle between the current channel and the reference channel waveforms.
PulseRepetitionFrequency | The pulse repetition frequency.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Measurement

The value returned by the instrument of the selected measurement function.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Measurement Read Waveform Measurement

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

MeasFunction (Rise Time)

Requests one of the measurement functions to be performed on the acquired waveform. Note: reference levels used by these measurements may be set using the Reference Level Configure VI
Supported functions are:

Name | Description
RiseTime | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
FallTime | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
Frequency | The frequency of one complete cycle in the waveform. The units are Hertz.
Period | The length of time of one complete cycle in the waveform. The units are seconds.
VoltageRMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
VoltagePeakToPeak | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
VoltageMax | The maximum amplitude found in the entire waveform. The units are Volts.
VoltageMin | The minimum amplitude found in the entire waveform. The units are Volts.
VoltageHigh | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.
VoltageLow | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.
VoltageAverage | The arithmetic average in volts measured over the entire waveform. The units are Volts.
WidthNeg | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
WidthPos | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
DutyCycleNeg | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
DutyCyclePos | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
Amplitude | The Voltage High less the Voltage Low in Volts over the entire waveform.
VoltageCycleRMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
VoltageCycleAverage | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
OverShoot | The relative waveform distortion that follows an edge transition.
PreShoot | The relative waveform distortion that precedes an edge transition.
DCOffset | The DC offset voltage.
PhaseAngle | The phase angle between the current channel and the reference channel waveforms.
PulseRepetitionFrequency | The pulse repetition frequency.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Query Board Temperature

This function is used to query the temperature of the entire board. The units are governed by the Temperature Units property.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Board Temperature

Returns whether the current temperature of the entire board. The units are governed by the Temperature Units property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Query Channel Temperature

This function is used to query the temperature of a specific channel. The units are governed by the Temperature Units property.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Channel Temperature

Returns the current temperature of the selected channel. The units are governed by the Temperature Units property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Read Waveform Int8

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Maximum Time (0)

Specifies the maximum time the end-user allows for this method to complete in milliseconds. Use '0' for immediate (no wait), and '-1' to wait indefinitely.

Waveform Array size (0)

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds.
Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

The seconds portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

The fractional portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Read Waveform Int16

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Maximum Time (0)

Specifies the maximum time the end-user allows for this method to complete in milliseconds.

Use '0' for immediate (no wait), and '-1' to wait indefinitely.

Waveform Array size (0)

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds.
Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

The seconds portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

The fractional portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Read Waveform Int32

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Maximum Time (0)

Specifies the maximum time the end-user allows for this method to complete in milliseconds. Use '0' for immediate (no wait), and '-1' to wait indefinitely.

Waveform Array size (0)

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds.
Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

The seconds portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

The fractional portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Read Waveform Real64

Initiates an acquisition on all enabled channels, waits (up to Maximum Time) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Maximum Time (0)

Specifies the maximum time the end-user allows for this method to complete in milliseconds. Use '0' for immediate (no wait), and '-1' to wait indefinitely.

Waveform Array size (0)

Number of elements in Waveform Array.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds.
Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

The seconds portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

The fractional portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Temperature Get Module Temperature

Returns the temperature of the specified module. The units are governed by the Temperature.Units property.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Module Number

The module number in a Multi-Instrument (ASBus), runs from 0 to (nbr of modules - 1).

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Val

Returned temperature value. The units are governed by the Temperature.Units property.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Data \ Low Level VIs

You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Methods (VIs) > Data \ Low Level VIs

Data \ Low-level VIs

Contained in this section are VI's which are used to access the low-level operations of the instrument.

Fetch Waveform Int8

Fetch Waveform Int16

Fetch Waveform Int32

Fetch Waveform Real64


AgMD1: Fetch Waveform Int8

Returns a previously acquired waveform for this channel.
The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Waveform Array size (0)

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds.
Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

The seconds portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

The fractional portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Fetch Waveform Int16

This VI returns the waveform the digitizer acquired for the specified channel.
The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Waveform Array size (0)

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds.
Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

The seconds portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

The fractional portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Fetch Waveform Int32

Returns a previously acquired waveform for this channel.
The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Waveform Array size (0)

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds.
Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

The seconds portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

The fractional portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

Scale Factor

Scaling factor for the waveform data.

Scale Offset

Scaling offset for the waveform data.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Fetch Waveform Real64

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel Name

The physical or virtual repeated capability identifier. In most cases, this would be <Channel1>, unless a virtual repeated capability has been defined in the Configuration Store for the Channel repeated capability. You can also pass an empty string if the device only has a single channel.

Waveform Array size (0)

Number of elements in WaveformArray.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Actual Points

Indicates how many data points were actually retrieved from the instrument.

First Valid Point

Indicates the index of the first valid data point in the output data array.

Initial X Offset

The time in relation to the Trigger Event of the first point in the waveform in seconds.
Negative values mean that the first point in the waveform array was acquired before the trigger event.

Initial X Time Seconds

The seconds portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

Initial X Time Fraction

The fractional portion of the absolute time at which the first data point was acquired.
Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

X Increment

The time between points in the acquired waveform in seconds.

Waveform Array

Buffer into which the acquired waveform is stored.

Numeric

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


Utility VIs

Contained in this section are VI's which are used to control various functions of the instrument.

Calibration Cal Required

Calibration Cancel

Calibration Load Cal

Calibration Save Cal

Calibration Self Calibrate

Disable

Error Message

Error Query

Get Delay Control Name

Reset

Resume Control

Suspend Control

Revision Query

Self Calibrate

Self Test

System Power Off All

System Power On All


AgMD1: Calibration Cal Required

Check if a self calibration is needed on the specified channel. (For 10-bit-FAMILY//U1071A-FAMILY)

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Channel (0)

Channel number [0,1...Nchan]. The value Channel = 0 can be used to do the query on all channels simultaneously.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Val

True if the specified channel requires calibration.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Calibration Cancel

Abort any running self-calibration and return.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Calibration Load Cal

Load calibration values and info from file. (For 10-bit-FAMILY//U1071A-FAMILY)

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

FilePathName

If an empty string is passed, it uses working directory and default file name of 'snXXXXX_calVal.bin'. If set to a path uses the specified directory with default file name. If a file name, with or without path, the specified name and path is used.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Calibration Save Cal

Save calibration values and info in a binary file. (For 10-bit-FAMILY//U1071A-FAMILY)

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

FilePathName

If an empty string is passed, it uses working directory and default file name of 'snXXXXX_calVal.bin'. If set to a path, it uses the specified directory with default file name. If a file name, with or without path, the specified name and path is used.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Calibration Self Calibrate

Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

Type (Full)

Type of self-calibration. Supported values are:

Name | Description
Full | Calibrate the entire instrument.
Channel Configuration | Calibrate only the current channel configuration.
Ext Clock Timing | Calibrate external clock timing. Requires operation in External Clock mode (Continuous).
Current Frequency | Calibrate only at the current frequency (only instruments with fine resolution timebases).
Fast | FastCal: calibrate only at the current settings (if supported). Warning: in this mode, any change of range, max input frequency, channel combine, input impedance or coupling, will require a new calibration.

Channel (0)

If supported for the chosen calibrate type, specifies the channel: 0 = calibrate all channels, >0 = calibrate only the specified channel.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Disable

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Error Message

Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error code (0)

Instrument driver status code.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error message

Instrument driver error message.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Error-Query

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error code

Instrument error code.

error message

Instrument error message.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Get Delay Control Name

Returns the delay control name that corresponds to the (one-based) index specified by the user.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Index

A one-based index that specifies which name to return.

NameBufferSize

The number of elements to assign for the name buffer.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Name

The returned name of the Delay Control that corresponds to the index that the user specifies. The caller may pass VI_NULL (0) for this parameter if the buffer size parameter is 0.


AgMD1: Reset

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: System Resume Control

Resume the control of an instrument that was suspended (see System Suspend Control).

This is only available for Windows operating systems.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: System Suspend Control

Suspend control of an instrument to allow using it from another process. (see System Resume Control)

This is only available for Windows operating systems.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Revision Query

Retrieves firmware revision information from the instrument, and driver revision.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

instrument driver revision

Returns the revision of the IVI specific driver.

firmware revision

Returns the firmware revision of the instrument, .

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Self Calibrate

Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
This operation can take 1-2 minutes to complete.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: Self-Test

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
This operation can take 1-2 minutes to complete.

This function actually performs an identical operation to the Self-Calibrate, but with the addition of an output message

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

self-test result

The numeric result from the self test operation. 0 = no error (test passed)

self-test message

The self test status message

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: System Power Off All

Forces all instruments to prepare and enter the system power down state and suspends all other calling threads.
If a thread is performing a long operation which cannot be completed within milliseconds (e.g. a self-calibration), it will be interrupted immediately and will return the status 'ACQIRIS_ERROR_OPERATION_INTERRUPTED'.

If an acquisition is still running when this method is invoked, it might be incomplete or corrupted.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1: System Power On All

Forces all instruments power up and return from the system power down state, and re-enables the instruments at the same state as they were before the PowerOffAll method was invoked. Threads which were suspended will be resumed. However, interrupted operations which returned an error 'ACQIRIS_ERROR_OPERATION_INTERRUPTED' will have to be re-done.

Inputs

instrument handle

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument IVI session.

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning.

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.

Outputs

instrument handle out

The Instrument Handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs. Getting more information about errors... The pop-up option Explain Error (or Explain Warning) gives more information about the errors displayed.

    status

    The status boolean is either TRUE [image] for an error, or FALSE [image] for no error or a warning..

    code

    The code input identifies the error or warning.

    source

    The source string describes the origin of the error or warning.


AgMD1 Attributes

This section provides technical and programming support for using the Agilent AgMD1 LabVIEW API VIs to develop applications for your Digitizers.

The Attributes are values used by certain of the Vi's to configure and return data about the state of the instrument.

ACQUISITION_AUTO_ARM_ENABLED

ACQUISITION_DITHER_ENABLED

ACQUISITION_DITHER_RANGE

ACQUISITION_MODE

ACQUISITION_NUMBER_OF_AVERAGES

ACQUISITION_REFERENCE_CHANNEL

ACQUISITION_START_TIME

ACQUISITION_TIME_PER_RECORD

ACTIVE_TRIGGER_SOURCE

BOARD_TEMPERATURE

CHANNEL_ACTIVE_INPUTS

CHANNEL_CONNECTOR_NAME

CHANNEL_CONVERTERS_PER_CHANNEL

CHANNEL_COUNT

CHANNEL_ENABLED

CHANNEL_INPUT_FREQUENCY_MAX

CHANNEL_PROBE_ATTENUATION

CHANNEL_TEMPERATURE

CONTROL_IO_SIGNAL_A

CONTROL_IO_SIGNAL_B

CONTROL_IO_SIGNAL_C

COUNTER_APETURE_TIME

COUNTER_MODE

DELAY_CONTROL_COUNT

DELAY_CONTROL_ENABLE

DELAY_CONTROL_MAX

DELAY_CONTROL_MIN

DELAY_CONTROL_VALUE

DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH

DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED

DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT

DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH

DOWNCONVERSION_CENTER_FREQUENCY

DOWNCONVERSION_ENABLED

DOWNCONVERSION_IQ_INTERLEAVED

DRIVER_SETUP

EXT_TRIG_RANGE

INPUT_CONNECTOR_SELECTION

INPUT_FILTER_BYPASS

INPUT_FILTER_MAX_FREQUENCY

INPUT_IMPEDANCE

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_INFO_AQ_DRV_VERSION

INSTRUMENT_INFO_AQIO_VERSION

INSTRUMENT_INFO_BUS_NUMBER

INSTRUMENT_INFO_CPLD_FIRMWARE_REV

INSTRUMENT_INFO_CRATE_ID

INSTRUMENT_INFO_CRATE_NUMBER

INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV

INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV

INSTRUMENT_INFO_FUNDAMENTAL_HANDLE

INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE

INSTRUMENT_INFO_NBRADC_BITS

INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS

INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS

INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT

INSTRUMENT_INFO_OPTIONS

INSTRUMENT_INFO_SERIAL_NUMBER

INSTRUMENT_INFO_SERIAL_NUMBER_STRING

INSTRUMENT_INFO_SLOT_NUMBER

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_RESOURCE_DESCRIPTOR

IS_IDLE

IS_MEASURING

IS_WAITING_FOR_ARM

IS_WAITING_FOR_TRIGGER

LOGICAL_NAME

LOGIC_DEVICE_COUNT

MAX_FIRST_VALID_POINT_VAL

MAX_SAMPLES_PER_CHANNEL

MEASUREMENT_WAVEFORM_TYPE

MIN_RECORD_SIZE

NUM_ACQUIRED_RECORDS

NUM_RECORDS_TO_ACQUIRE

PXI_TRIG_OUT_ENABLED

PXI_TRIG_SLOPE

RECORD_SIZE

REFERENCE_LEVEL_HIGH

REFERENCE_LEVEL_LOW

REFERENCE_LEVEL_MID

REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

REFERENCE_OSCILLATOR_SOURCE

REFERENCE_OSCILLATOR_OUTPUT_ENABLED

SAMPLE_CLOCK_EXTERNAL_DIVIDER

SAMPLE_CLOCK_EXTERNAL_FREQUENCY

SAMPLE_CLOCK_SOURCE

SAMPLE_MODE

SAMPLE_RATE

SIMULATE

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

SUPPORTED_INSTRUMENT_MODELS

SYSTEM_TRACE_ENABLED

SYSTEM_NBR_INSTRUMENTS

TEMPERATURE_UNITS

TIME_INTERLEAVED_CHANNEL_LIST

TRIGGER_COUPLING

TRIGGER_DELAY

TRIGGER_LEVEL

TRIGGER_MAGNITUDE_SLOPE

TRIGGER_MODIFIER

TRIGGER_OUTPUT_ENABLED

TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED

TRIGGER_OUTPUT_OFFSET

TRIGGER_OUTPUT_RESYNC

TRIGGER_OUTPUT_SOURCE

TRIGGER_SLOPE

TRIGGER_SOURCE_COUNT

TRIGGER_SOURCE_LIST

TRIGGER_SOURCE_OPERATOR

TRIGGER_TYPE

TV_TRIGGER_POLARITY

TV_TRIGGER_EVENT

TV_TRIGGER_LINE_NUMBER

TV_TRIGGER_SIGNAL_FORMAT

VERTICAL_COUPLING

VERTICAL_OFFSET

VERTICAL_RANGE


ACQUISITION_AUTO_ARM_ENABLED

If true, arming is enabled. After an acquisition has been initiated, SendSoftwareArm VI must be used before any triggers will be accepted.

Data Type

Boolean
Supported Values
True | Arming is enabled
False | Arming is disabled
Notes

Requires model: M9202A


ACQUISITION_DITHER_ENABLED

Enables or disables the Dithering function, which improves the linearity performance of the ADC

Data Type

Boolean
Supported Values
True | Dithering is enabled
False | Dithering is disabled
Notes

Requires model: M9202A


ACQUISITION_DITHER_RANGE

Sets amplitude of dithering signal. Range: 0 to 31.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | No dithering | Dithering amplitude is 0
to |  |
0x00000031 | Full dithering | Dithering amplitude is Full Scale/2 = 500 mV
Notes

Requires model: M9202A


ACQUISITION_MODE

The acquisition mode, Normal digitizer or digital Downconverter.

Data Type

Integer32
Supported Values
0x00000000 | Normal | Normal digitizer mode
0x0000000C | Downconverter | Digital Downconverter mode
Notes

Downconverter mode requires model: M9202A


ACQUISITION_NUMBER_OF_AVERAGES

The number of waveforms the digitizer acquires and averages before returning to the idle state.

Averaged waveforms must be read using the Measurement.ReadWaveform VI's.

Data Type

Integer32
Notes

Averaging is not supported (ignored) by all FetchWaveform methods.


ACQUISITION_REFERENCE_CHANNEL

The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly.

Data Type

String
Supported Values

Channel<n>

Channel name

Where <n> is a valid channel number for the instrument


ACQUISITION_START_TIME

Specifies the length of time from the trigger event to the first point in the waveform record.

The units are seconds.

Data Type

Real64
Supported Values
negative | Pre-Trigger | If the value is negative, the first point in the waveform record occurs before the trigger event.
positive | Post-Trigger | If the value is positive, the first point in the waveform record occurs after the trigger event


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > ACQUISITION_TIME_PER_RECORD

ACQUISITION_TIME_PER_RECORD

The time in seconds that corresponds to the record length.

Data Type

Real64


ACTIVE_TRIGGER_SOURCE

Specifies the source the digitizer monitors for the trigger event.

Data Type

String
Supported Values
'Channel<n>' | where <n> = a valid channel number
'External<n>' | where <n> = a valid channel number
'PXI_STAR' | Triggers from the PXI star trigger
Notes

The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability


BOARD_TEMPERATURE

Indicates the temperature of the entire board.

Data Type

Real64, Read-Only
Notes

The units are governed by the Temperature Units attribute.


CHANNEL_ACTIVE_INPUTS

String indicating which channels are active.

Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc.

Data Type

String


CHANNEL_CONNECTOR_NAME

The connector name as it appears on the instrument's front panel.

Data Type

String, Read-Only


CHANNEL_CONVERTERS_PER_CHANNEL

The number of converters currently assigned to each channel.

Data Type

Unsigned Integer32, Read-Only


CHANNEL_COUNT

The number of channels present on the instrument.

Data Type

Unsigned Integer32, Read-Only


CHANNEL_ENABLED

Specifies whether the digitizer acquires a waveform for the channel.

Data Type

Boolean
Supported Values
True | A waveform is acquired for the selected channel.
False | A waveform is not acquired for the selected channel.


CHANNEL_INPUT_FREQUENCY_MAX

The maximum input frequency of this channel.

i.e the frequency at which the input circuitry attenuates the input signal by 3 dB.

The units are hertz.

Data Type

Real64
Notes

Returns 0.0 when no filter is set (i.e. max bandwidth).


CHANNEL_PROBE_ATTENUATION

The scaling factor by which the probe attenuates the input signal.

For example, for a 10:1 probe, the value would be 10.0.

Data Type

Real64


CHANNEL_TEMPERATURE

Indicates the temperature of the channel.

Data Type

Real64, Read-Only
Notes

The units are governed by the Temperature Units attribute.


CONTROL_IO_SIGNAL_A

Selects the signal presented on Control IO connector A.

Valid strings are shown in the table below.

Data Type

String
Supported Values
Disabled | ----- | No signal present on connector.
In-GateForTriggerAND | Input | Enable trigger input (for Digitizers). If one of the two I/O connectors is set to this value, then a high level must be present before an edge can be accepted. If both I/O connectors are set to this value, they both must be high before an edge can be accepted.
Out-10MHzReferenceClock | Output | 10 MHz reference clock.
Out-AcquisitionActive | Output | Acquisition is active.
Out-SkippingToNextSeg | Output | Acquisition skipping to next segment.
Out-TriggerArmed | Output | Trigger is armed (ready).
Out-LowLevel | Output | Output is held in the high state (for test purposes)
Out-HighLevel | Output | Output is held in the low state (for test purposes)
Out-TriggerAcceptedResync | Output | Signal indicating that a valid trigger has occurred, re-synchronized to the clock.


CONTROL_IO_SIGNAL_B

Selects the signal presented on Control IO connector B.

Valid strings are shown in the table below:

Data Type

String
Supported Values
Disabled | ----- | No signal present on connector.
In-GateForTriggerAND | Input | Enable trigger input (for Digitizers). If one of the two I/O connectors is set to this value, then a high level must be present before an edge can be accepted. If both I/O connectors are set to this value, they both must be high before an edge can be accepted.
Out-10MHzReferenceClock | Output | 10 MHz reference clock.
Out-AcquisitionActive | Output | Acquisition is active.
Out-SkippingToNextSeg | Output | Acquisition skipping to next segment.
Out-TriggerArmed | Output | Trigger is armed (ready).
Out-LowLevel | Output | Output is held in the high state (for test purposes)
Out-HighLevel | Output | Output is held in the low state (for test purposes)
Out-TriggerAcceptedResync | Output | Signal indicating that a valid trigger has occurred, re-synchronized to the clock.


CONTROL_IO_SIGNAL_C

Selects the signal presented on Control IO connector C.

Valid strings are shown in the table below.

Data Type

String
Supported Values
Disabled | ----- | No signal present on connector.
In-GateForTriggerAND | Input | Enable trigger input (for Digitizers). If one of the two I/O connectors is set to this value, then a high level must be present before an edge can be accepted. If both I/O connectors are set to this value, they both must be high before an edge can be accepted.
Out-10MHzReferenceClock | Output | 10 MHz reference clock.
Out-AcquisitionActive | Output | Acquisition is active.
Out-SkippingToNextSeg | Output | Acquisition skipping to next segment.
Out-TriggerArmed | Output | Trigger is armed (ready).


COUNTER_APETURE_TIME

The minimum measurement time for Frequency and Period modes.

The duration to count input pulses for TotalizeGate mode. The Counter.Read method will wait this time before returning measurement data.

Units are seconds.

Data Type

Real64
Notes

Requires model: DC135, DC135HZ, DC140, DC140HZ


COUNTER_MODE

The mode for counter measurements, Frequency, Period, TotalizeTime, or TotalizeGate.

Data Type

Integer32
Supported Values
AGMD1_VAL_COUNTER_MODE_FREQUENCY | Counter measures the frequency of the input signal.
AGMD1_VAL_COUNTER_MODE_PERIOD | Counter measures the period of the input signal.
AGMD1_VAL_COUNTER_MODE_TOTALIZE_TIME | Counts input pulses during the interval defined by COUNTER_APETURE_TIME.
AGMD1_VAL_COUNTER_MODE_TOTALIZE_GATE | Counts input pulses during the interval defined by I/O A or B input.
Notes

Requires models: DC135, DC135HZ, DC140, DC140HZ


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > DELAY_CONTROL_COUNT

DELAY_CONTROL_COUNT

Returns the number of delay controls available.

Data Type

Integer32, Read-Only


DELAY_CONTROL_ENABLE

Specifies whether the delay controls are set manually

Data Type

Boolean
Supported Values
True | All delay controls must be set manually.
False | The delay controls are set by the self-calibration.


DELAY_CONTROL_MAX

Maximum value (DAC code) that can be set for the delay control.

Data Type

Integer32, Read-Only


DELAY_CONTROL_MIN

Minimum value (DAC code) that can be set for the delay control.

Data Type

Integer32, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > DELAY_CONTROL_VALUE

DELAY_CONTROL_VALUE

The value (DAC code) set for the delay control.

Data Type

Integer32


DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH

The DataBandwidth setting sets the amount of digital filtering applied to the data prior to storage or streaming. The setting of DataBandwidth indirectly sets the output sample rate.

The available choices for DataBandwidth are either wide-open (= 250 MHz) and 200 MHz / 2^n, where n = 0, 1, 2, …, 18.

Data Type

Real64
Supported Values
250e6 | 250 MHz | No filtering applied
200e6 | 200 MHz | n = 0
100e6 | 100 MHz | n = 1
50e6 | 50 MHz | n = 2
..... | ..... | .....
763e0 | 763 Hz | n = 18
Notes

Requires model: M9202A

Please refer to the Remarks in the M9202A Digitizer in DDC mode topic for detailed information on programming when in digital downconversion mode.


DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED

The FlipBand setting controls wether the 500 MHz shift is +500 MHz or -500 MHz

Data Type

Boolean
Supported Values
True | First frequency shift is by -500 MHz
False | First frequency shift is by +500 MHz
Notes

Requires model: M9202A

Please refer to the Remarks in the M9202A Digitizer in DDC mode topic for detailed information on programming when in digital downconversion mode.


DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT

Used to set up the frequency shift blocks of the down converter.

The value of this attribute corresponds to the data frequency shift, whereas the trigger frequency shift is the nearest value available with the given TriggerBandwidth.

i.e. the trigger frequency shift equals FrequencyShift if TriggerBandwidth <= DataBandwidth; otherwise it is rounded to the nearest multiple of TriggerBandwidth * 2.5 / 4.

Data Type

Supported Values
-125e6 | -125 MHz |
to | to | In steps of: DataBandwidth * 2.5 / 4
+125e6 | +125 MHz |
Notes

Requires model: M9202A

Please refer to the Remarks in the M9202A Digitizer in DDC mode topic for detailed information on programming when in digital downconversion mode.


DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH

The output bandwidth in Hz for down-converted trigger.

The available choices for TriggerBandwidth are either wide-open (= 250 MHz) and 200 MHz / 2^n, where n = 0, 1, 2, …, 18.

Data Type

Real64
Supported Values
250e6 | 250 MHz | No filtering applied
200e6 | 200 MHz | n = 0
100e6 | 100 MHz | n = 1
50e6 | 50 MHz | n = 2
..... | ..... | .....
763e0 | 763 Hz | n = 18
Notes

Requires model: M9202A

Please refer to the Remarks in the M9202A Digitizer in DDC mode topic for detailed information on programming when in digital downconversion mode.


DOWNCONVERSION_CENTER_FREQUENCY

Specifies the center frequency, in Hz, from which the digitizer should downconvert.

Data Type

Double (Real64)
Notes

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.


DOWNCONVERSION_ENABLED

Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.

Data Type

Boolean
Notes

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.


DOWNCONVERSION_IQ_INTERLEAVED

Controls how the Read and Fetch functions return data when downconversion is enabled.

When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.

Data Type

Boolean

Supported Values

True | Read and Fetch functions return data with the I and Q data points interleaved.
False | Read and Fetch functions return data with all I data points in sequence followed by all Q data points

Notes

Note that the M9703A only supports interleaved I-Q data points, and each I-Q pair is treated as one complex sample.

Please refer to the Remarks in the M9703A Digitizer in DDC mode topic for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.


DRIVER_SETUP

The driver setup string.

It is either specified in the Configuration Store or passed in the OptionString parameter of the InitializeWithOptions function.

Data Type

String, Read-Only
Notes

Driver setup is empty if the driver is not initialized.


EXT_TRIG_RANGE

The absolute value of the trigger signal range the digitizer can use for the external trigger input.

The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Data Type

Real64


INPUT_CONNECTOR_SELECTION

Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling. Multiple signals can be routed to the various connectors, then the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used.

Data Type

Unsigned Integer32
Supported Values
0x00000001 | Connector 1 is used
0x00000002 | Connector 2 is used


INPUT_FILTER_BYPASS

Specifies whether or not to bypass the input filter.

Data Type

Boolean
Supported Values
True | The input filter is bypassed
False | The input filter is used.


INPUT_FILTER_MAX_FREQUENCY

Specifies the maximum input filter frequency.

The units are Hertz.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Notes

Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed.


INPUT_IMPEDANCE

The input impedance of the channel. The units are Ohms.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, refer to the specific instrument user guide for information.


INSTRUMENT_FIRMWARE_REVISION

The firmware revision reported by the physical instrument.

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_AQ_DRV_VERSION

INSTRUMENT_INFO_AQ_DRV_VERSION

Version of the AqDrv Device Driver.

Data Type

String, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_AQIO_VERSION

INSTRUMENT_INFO_AQIO_VERSION

Version of the Agilent Acqiris IO Driver.

Data Type

String, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_BUS_NUMBER

INSTRUMENT_INFO_BUS_NUMBER

PCI Bus number.

Data Type

Unsigned Integer32, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_CPLD_FIRMWARE_REV

INSTRUMENT_INFO_CPLD_FIRMWARE_REV

Revision of the CPLD Firmware.

Data Type

String, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_CRATE_ID

INSTRUMENT_INFO_DEVICE_ID

PCI Device ID.

Data Type

Unsigned Integer32, Read-Only


INSTRUMENT_INFO_CRATE_NUMBER

Crate number.

Starts at 121000 for autodetected CC121 crates.

Data Type

Integer32, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV

INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV

Revision of the EEPROM Common Section.

Data Type

String, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV

INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV

Revision of the EEPROM Digitizer Section.

Data Type

String, Read-Only


INSTRUMENT_INFO_FUNDAMENTAL_HANDLE

Returns the Int32 equivalent ViSession handle to the fundamental API used to control the module hardware.

Never call the fundamental Acqrs_close or Acqrs_closeAll functions with this handle or the driver will cease to operate. Use the IVI driver's Close method instead.

Data Type

Integer32 Read-Only


INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE

True if the instrument features a high resolution sampling rate.

Data Type

Boolean, Read-Only


INSTRUMENT_INFO_NBRADC_BITS

Number of bits of data per sample from this module's ADCs.

Data Type

Unsigned Integer32, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS

INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS

Number of external trigger sources.

Data Type

Unsigned Integer32, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS

INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS

Number of internal trigger sources.

Data Type

Unsigned Integer32, Read-Only


INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT

Number of modules in this instrument. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Individual modules (not connected by ASBus) return 1.

Data Type

Unsigned Integer32, Read-Only


INSTRUMENT_INFO_OPTIONS

List of comma separated options installed in this instrument.

Data Type

String, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_SERIAL_NUMBER

INSTRUMENT_INFO_SERIAL_NUMBER

The serial number of the instrument.

Data Type

Unsigned Integer32, Read-Only


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > INSTRUMENT_INFO_SERIAL_NUMBER_STRING

INSTRUMENT_INFO_SERIAL_NUMBER_STRING

The serial number string of the instrument. Read only

Data Type

String Read-Only


INSTRUMENT_INFO_SLOT_NUMBER

The slot number as indicated on the crate's front panel (for Agilent Acqiris CCxxx crates).

Data Type

Unsigned Integer32, Read-Only


INSTRUMENT_MANUFACTURER

The name of the manufacturer reported by the physical instrument.

Manufacturer is limited to 256 bytes

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition.


INSTRUMENT_MODEL

The model number or name reported by the physical instrument.

Model is limited to 256 bytes

Data Type

String, Read-Only
Notes

If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition.


IO_RESOURCE_DESCRIPTOR

The resource descriptor specifies the connection to a physical device.

It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function.

Data Type

String, Read-Only
Notes

It is empty if the driver is not initialized.


IS_IDLE

Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Unsigned Integer32, Read-Only
Supported Values
0x00000001 | Instrument is in the Idle state
0x00000002 | Instrument in not in the Idle state
0x00000003 | The state of the instrument is unknown


IS_MEASURING

Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Unsigned Integer32, Read-Only
Supported Values
0x00000001 | The instrument is currently in the Measuring state
0x00000002 | The instrument is not in the Measuring state
0x00000003 | The driver cannot query the instrument to determine if the digitizer is in the Measuring state.


IS_WAITING_FOR_ARM

Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Unsigned Integer32, Read-Only
Supported Values
0x00000001 | The instrument is currently Waiting for Arm
0x00000002 | The instrument is not Waiting for Arm
0x00000003 | The driver cannot query the instrument to determine if the digitizer is Waiting for Arm.


IS_WAITING_FOR_TRIGGER

Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Data Type

Unsigned Integer32, Read-Only
Supported Values
0x00000001 | The instrument is currently waiting for a trigger event
0x00000002 | The instrument is not waiting for a trigger
0x00000003 | The driver cannot query the instrument to determine if the digitizer is Waiting for trigger event


LOGICAL_NAME

Logical Name identifies a driver session in the Configuration Store.

Data Type

String, Read-Only
Notes

If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.


You are here: AgMD1 LabVIEW G Driver > Programming Reference > AgMD1 Attributes > LOGIC_DEVICE_COUNT

LOGIC_DEVICE_COUNT

Returns the number of logic devices.

Data Type

Integer32, Read-Only


MAX_FIRST_VALID_POINT_VAL

Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieve the entire acquisition.

Data Type

Integer64


MAX_SAMPLES_PER_CHANNEL

Returns the maximum number of samples per channel that can be captured.

Data Type

Integer64, Read-Only


MEASUREMENT_WAVEFORM_TYPE

Waveform type used to calculate measurement function values by the FetchWaveformMeasuerment and ReadWaveformMeasurement methods. See the Data VI's section for information in these functions.

Data Type

Integer32
Supported Values
0x00000000 | Unknown | This value indicates that the signal is of an unspecified waveform type.
0x00000001 | Sine | The signal is a sine waveform.
0x00000002 | Square | The signal is a square waveform.
0x00000003 | Ramp | The signal is a ramp or triangle waveform.
0x00000004 | Pulsed DC | The signal is a pulsed DC waveform.
0x00000005 | Step | The signal is a step waveform.


MIN_RECORD_SIZE

Indicates the minimum waveform record size.

Data Type

Integer64, Read-Only
Notes

If the digitizer can support any arbitrary size record, then this attribute returns 1.


NUM_ACQUIRED_RECORDS

Gets the total number of records acquired since the acquisition was last initiated.

Data Type

Integer64, Read-Only
Notes

You may check this value while an acquisition is in progress.


NUM_RECORDS_TO_ACQUIRE

Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.

Data Type

Integer64


PXI_TRIG_OUT_ENABLED

Enables PXI trigger out signal.

Data Type

Boolean
Supported Values
True | PXI Trigger Out signal is enabled
False | PXI Trigger Out signal is disabled
Notes

Not allowed when ActiveTriggerSource is "PXI_STAR" as this uses the PXI signal as the trigger input.


PXI_TRIG_SLOPE

Specifies whether a rising or a falling edge triggers the digitizer.

This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR".

Data Type

Integer32
Supported Values
AGMD1_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level, triggers the digitizer.
AGMD1_VAL_POSITIVE | A positive (rising) edge passing through the trigger level, triggers the digitizer.


RECORD_SIZE

Specifies the number of samples to acquire in each waveform record.

Data Type

Integer64


REFERENCE_LEVEL_HIGH

The high reference for waveform measurements.

It is a percentage of the amplitude difference between the Voltage High and Voltage Low values.

Data Type

Real64
Notes

Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.


REFERENCE_LEVEL_LOW

The low reference for waveform measurements.

It is a percentage of the difference between the Voltage High and Voltage Low.

Data Type

Real64
Notes

Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.


REFERENCE_LEVEL_MID

The mid reference for waveform measurements.

It is a percentage of the difference between the Voltage High and Voltage Low.

Data Type

Real64
Notes

Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.


REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY

Specifies the frequency of the external signal which is used as a frequency reference.

The units are Hertz.

Data Type

Real64
Notes

This value is used only if the Reference Oscillator Source attribute is set to External.


REFERENCE_OSCILLATOR_SOURCE

Specifies the reference frequency source used.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | The internal reference oscillator is used.
0x00000001 | An external reference oscillator is used.
0x00000002 | PXI 10 MHz reference clock is used.
0x00000003 | PXIe 100 MHz reference clock is used.
0x00000004 | AXIe 100 MHz reference clock is used.

The validity of these values is model dependant, please check the capability of your particular model.


REFERENCE_OSCILLATOR_OUTPUT_ENABLED

Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.

Data Type

Boolean
Supported Values
True | The reference oscillator output signal is enabled.
False | The reference oscillator output is disabled.


SAMPLE_CLOCK_EXTERNAL_DIVIDER

Specifies the value by which the external sample clock should be divided.

Data Type

Real64
Notes

This value is used only if the Sample Clock Source attribute is set to External.


SAMPLE_CLOCK_EXTERNAL_FREQUENCY

Specifies the frequency of the external signal which is used as a sample clock.

The units are Hertz.

Data Type

Real64
Notes

This value is used only if the Sample Clock Source attribute is set to External.


SAMPLE_CLOCK_SOURCE

Specifies the clock used to pace acquisition sampling.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | The internal sample clock is used.
0x00000001 | An external sample clock is used.


SAMPLE_MODE

Specifies the sample mode used by the digitizer.

Data Type

Unsigned Integer32
Notes

-- NOT SUPPORTED, Always RealTime mode --


SAMPLE_RATE

Specifies the rate of the sample clock in samples per second.

This number represents the inverse of the interval between samples in the acquisition record. i.e Sample/s = 1/f

Data Type

Real64


SIMULATE

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

Data Type

Boolean
Supported Values
True | The instrument simulates values for output parameters.
False | The instrument operates normally.


SPECIFIC_DRIVER_DESCRIPTION

Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


SPECIFIC_DRIVER_REVISION

Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


SPECIFIC_DRIVER_VENDOR

Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Data Type

String, Read-Only


SUPPORTED_INSTRUMENT_MODELS

A comma-separated list of instrument models that the IVI specific driver can control.

Data Type

String, Read-Only
Notes

The string does not include an abbreviation for the manufacturer if it is the same for all models.


SYSTEM_TRACE_ENABLED

If true, outputs a trace log of all driver calls to an xml file in the same directory as the application executable accessing the driver. Generates default unique file names based on date and time. A new file is generated each time tracing is enabled.

Data Type

Boolean
Supported Values
True | System trace is enabled
False | System trace is disabled


SYSTEM_NBR_INSTRUMENTS

The number of instruments supporting the AgMD1 driver in the system. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors.

Data Type

Unsigned Integer32, Read-Only


TEMPERATURE_UNITS

Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | Temperature values returned from the digitizer are in degrees Celsius.
0x00000001 | Temperature values returned from the digitizer are in degrees Fahrenheit.
0x00000002 | Temperature values returned from the digitizer are in degrees Kelvin.


TIME_INTERLEAVED_CHANNEL_LIST

This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.

Data Type

String


TRIGGER_COUPLING

Specifies how the digitizer couples the trigger source.

Data Type

Integer32
Supported Values
0x00000000 | AC | The digitizer AC couples the trigger signal.
0x00000001 | DC | The digitizer DC couples the trigger signal.
0x00000002 | HF Reject | The digitizer filters out the high frequencies from the trigger signal.


TRIGGER_DELAY

Specifies the length of time from the trigger event to the first point in the waveform record.

The units are seconds.

Data Type

Real64
Supported Values
negative | Pre-Trigger | If the value is negative, the first point in the waveform record occurs before the trigger event.
positive | Post-Trigger | If the value is positive, the first point in the waveform record occurs after the trigger event


TRIGGER_LEVEL

Specifies the voltage threshold for the trigger sub-system.

The units are Volts.

Data Type

Real64
Notes

This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger.

This attribute, along with the Trigger Slope, Active Trigger Source, and Trigger Coupling attributes, define the trigger event when the Trigger Type is set to Edge Trigger.


TRIGGER_MAGNITUDE_SLOPE

Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.

Data Type

Integer32
Supported Values
AGMD1_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level, triggers the digitizer.
AGMD1_VAL_POSITIVE | A positive (rising) edge passing through the trigger level, triggers the digitizer.
Notes

Requires model: M9202A


TRIGGER_MODIFIER

Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.

Data Type

Unsigned Integer32
Supported Values
0x00000001 | None | The digitizer waits until the trigger the end-user specifies occurs.
0x00000002 | Auto | The digitizer automatically triggers if the configured trigger does not occur within the digitizer timeout period.


TRIGGER_OUTPUT_ENABLED

Specifies whether or not an accepted trigger appears at an output of the digitizer.

Data Type

Boolean
Supported Values
True | The trigger appears at the output of the digitizer.
False | The trigger output is disabled.


TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED

M9202A Multi Module Synchronization.

Enables a M9202A to be the trigger master to synchronize multiple other M9202A modules (trigger slave modules). For all modules to synchronize, only one module can be the trigger master module while all others must be trigger slave modules. The trigger master module will drive the front panel TRG OUT output connector with a trigger signal that must be connected to the external trigger input :

1. TRG1 of the slave modules AND TRG1 of the master module, when the trigger Type of the master modules is set to Magnitude trigger. In this case, all modules will show an identical trigger delay and will be tightly synchronized.

2. TRG1 of the slaves modules only, when the master module is configured in External trigger, i.e. ActiveSource = "External1". In this case, the master module will show a trigger delay of -25 ns compared to the slave modules. The trigger delay difference can be compensated using the trigger delay controls.

Data Type

Boolean
Supported Values
True | Multi Module Synchronization is enabled.
False | Multi Module Synchronization is disabled.


TRIGGER_OUTPUT_OFFSET

Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range).

Units are Volts.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, refer to the specific instrument user guide for information.


TRIGGER_OUTPUT_RESYNC

Controls whether the trigger out signal is re-synchronized to the sampling clock (true) or maintains a precise timing relation to the trigger input (false).

Data Type

Boolean
Supported Values
Value | Trigger output is re-synchronized to the sampling clock
Value | Trigger output maintains precise timing to the trigger input


TRIGGER_OUTPUT_SOURCE

Selects the trigger source to drive the TRG OUT output connector on the front panel.

Possible values are "Channel1" to "Channel<n>" or "External1" to "External<n>" trigger sources.

Data Type

String
Supported Values
Channel<1..n> | Specifies channel<n> | Where <n> is the number of available channels.
External<1..n> | Specifies external trigger <n> | Where <n> is the number of available external trigger inputs.
TriggerCompare | Trigger source conditions have been met. (Not necessarily triggered) | (M97xxA only)
TriggerAccepted | Trigger source conditions have been met & trigger was enabled - Trigger has occurred. | (M97xxA only)
AXIe_TRIG<0..11> | One of 12 AXIe bus trigger lines (output). | (M97xxA only)
AXIe_STRIG | The AXIe star trigger | (M97xxA only)
HighLevel | Output is held high (for test purposes) | (M97xxA only)
LowLevel | Output is held low (for test purposes) | (M97xxA only)


TRIGGER_SLOPE

Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | Negative | A negative (falling) edge passing through the trigger level triggers the digitizer.
0x00000001 | Positive | A positive (rising) edge passing through the trigger level triggers the digitizer.


TRIGGER_SOURCE_COUNT

The number of trigger sources present on the instrument.

Data Type

Integer32, Read-Only


TRIGGER_SOURCE_LIST

A comma separated list of source names to be used in a multi trigger scenario.

This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satisfied in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer.

Data Type

String
Supported Values

Any valid name used for the Active Trigger Source attribute may be used in this list. A trigger source may appear only once in the list.
Notes

If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.


TRIGGER_SOURCE_OPERATOR

Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute. See the definition of that attribute for details.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | AND | Trigger sources are logically AND'd together. The digitizer triggers when all configured trigger source conditions are satisfied.
0x00000001 | OR | Trigger sources are logically OR'd together. The digitizer triggers when the first configured trigger source condition is satisfied.
0x00000002 | None | No operator is applied to the configured list of trigger sources. The trigger source list is ignored, and the digitizer triggers when the currently configured trigger source, given by the Active Trigger Source attribute, and its associated trigger conditions are satisfied.


TRIGGER_TYPE

The kind of event that triggers the digitizer.

Data Type

Unsigned Integer32
Supported Values
0x00000001 | Edge Trigger | Configures the digitizer for edge triggering. An edge trigger occurs when the trigger signal specified with the Active Trigger Source attribute passes the voltage threshold specified with the Trigger Level attribute and has the slope specified with the Trigger Slope attribute.
0x00000005 | TV Trigger | Configures the digitizer for triggering on TV signals. Use the Configure TV Trigger Source.vi to configure the trigger.
0x000003E9 | Immediate Trigger | Immediately triggers the measurement.
0x000003EA | Magnitude Trigger | Magnitude triggering. Only valid when Acquisition Mode = Downconverter. Requires model: M9202A
Notes

TV triggering requires External trigger source.


TV_TRIGGER_POLARITY

Specifies the polarity of the TV signal.

Data Type

Unsigned Integer32
Supported Values
0x00000001 | Positive | Configures the digitizer to trigger on a positive video sync pulse.
0x00000002 | Negative | Configures the digitizer to trigger on a negative video sync pulse.


TV_TRIGGER_EVENT

Specifies the TV event on which the digitizer triggers.

Data Type

Unsigned Integer32
Supported Values
0x00000001 | Field 1 | Sets the digitizer to trigger on field 1 of the video signal.
0x00000002 | Field 2 | Sets the digitizer to trigger on field 2 of the video signal.
0x00000005 | Line Number | Sets the digitizer to trigger on a specific line number you specify with the TV Trigger Line Number attribute.


TV_TRIGGER_LINE_NUMBER

Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number.

Data Type

Unsigned Integer32
Notes

The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).


TV_TRIGGER_SIGNAL_FORMAT

Specifies the format of TV signal on which the digitizer triggers.

Data Type

Unsigned Integer32
Supported Values
0x00000001 | NTSC | Configures the digitizer to trigger on the NTSC signal format.
0x00000002 | PAL | Configures the digitizer to trigger on the PAL signal format
0x00000003 | SECAM | Configures the digitizer to trigger on the SECAM signal format


VERTICAL_COUPLING

Specifies how the digitizer couples the input signal for the channel.

Data Type

Unsigned Integer32
Supported Values
0x00000000 | The digitizer AC couples the input signal.
0x00000001 | The digitizer DC couples the input signal.
0x00000002 | The digitizer couples the channel to the ground.


VERTICAL_OFFSET

The location of the center of the range that you specify with the Vertical Range attribute.

The units are Volts, with respect to ground.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Notes

For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.


VERTICAL_RANGE

The absolute value of the input range the digitizer can acquire for the channel.

The units are Volts.

Data Type

Real64
Supported Values

Allowed values are instrument dependant, please refer to the instrument user guide for more information.
Notes

For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.